# Table of Contents

**Notices** .................................................. 3  
Trademark .................................................. 3  
Copyright .................................................. 3  
Contacting Support ......................................... 3  

**Chapter 1: Introduction** ................................. 4  
Overview .................................................... 4  
Supported Files and Systems ............................... 4  
Installation .................................................. 4  
User-interface Overview .................................... 5  
Application Menus .......................................... 6  
In This Manual .............................................. 9  

**Chapter 2: Operation** ............................... 10  
Using the Bin ............................................... 10  
Playback Tab ................................................ 12  
Capture Tab ................................................. 14  
  Capture Dashboard ........................................ 16  
  Batch Capture ............................................ 16  
Edit-To-Tape Tab ........................................... 18  
  Edit Settings Pane ....................................... 19  
Tape Deck Timing Adjustment ............................. 20  
  Capture Timing ......................................... 20  
  Edit-to-Tape Timing .................................... 21  

**Appendix A: Python Scripting Tutorial** ............... 22  
Python Installation ....................................... 22  
  Windows ............................................... 22  
  Apple Macintosh ...................................... 22  
AJA Control Room Setup for Python Scripting ........... 23  
  Macintosh Instructions ................................ 23  
  Windows Instructions .................................. 24  
Simple Modifications ..................................... 24
Notices

Trademarks

AJA®, KONA®, Ki Pro®, KUMO® and XENA® are registered trademarks of AJA Video, Inc., TruZoom™, TruScale™, Ki Pro Mini™, Io Express™, Io HD”, Io” AJA Control Room™, and “Work. Flow.” are trademarks of AJA Video, Inc. AirPort, Apple, the Apple logo, AppleShare, AppleTalk, FireWire, iPod, iPod Touch, Mac, and Macintosh are registered trademarks of Apple Computer, Inc. Final Cut Pro, QuickTime and the QuickTime Logo are trademarks of Apple Computer, Inc. Avid, Avid Media Composer and Avid DNxHD are trademarks of Avid Technology, Inc. All other trademarks are the property of their respective holders.

HDMI, the HDMI logo and High-Definition Multimedia Interface are trademarks or registered trademarks of HDMI Licensing LLC. DVI is a registered trademark of DDWG. All other trademarks are the property of their respective holders.

Copyright

Copyright © 2014 AJA Video, Inc. All rights reserved. All information in this manual is subject to change without notice. No part of the document may be reproduced or transmitted in any form, or by any means, electronic or mechanical, including photocopying or recording, without the express written permission of AJA Inc.

Contacting Support

When calling for support, have all information at hand prior to calling.

To contact AJA Video for sales or support, use any of the following methods:

Telephone: +1.530.271.3190
Fax: +1.530.271.3140
Web: http://www.aja.com
Support Email: support@aja.com
Sales Email: sales@aja.com
Chapter 1: Introduction

Overview

AJA Control Room™ is a simple software application for professional quality video and audio capture, conversion, playback, and output. With AJA Control Room you can master-to-tape using a single application. You can configure your video/audio I/O via an AJA edit device using the AJA Control Panel launched from the AJA Control Room application.

AJA Control Room is available for Mac OS X and Windows. This chapter provides a brief overview of the application's layout and functions.

Supported Files and Systems

AJA Control Room supports common video and graphic file types, including QuickTime (.mov), and DPX. You can use AJA Control Room with a variety of AJA video and audio processing hardware products.

Installation

AJA Control Room software is available from the AJA website:


1. Locate and click the AJA Control Room download link to download the product.
2. Once the compressed product file is on your machine, double-click the file to open it.
3. (Windows) Follow the installation wizard instructions to install AJA Control Room.
4. (Mac) Drag the app files to the Application folder.
5. After installation, the applications are ready to run.
User-interface Overview

This section discusses the general layout and functions offered in AJA Control Room application menu bar and user interface screen. The application, by default, opens to the Viewer page shown in the following figure (the default Viewer Tab is Playback).

**Figure 1. AJA Control Room Screen Layout**

- **Playback**—the playback pane loads files from your computer and plays them out through your AJA hardware.

**NOTE:** Tabs at the top of the Viewer Screen allow you to easily toggle between Capture, Playback and Edit To Tape. The Capture and Edit To Tape screen tabs are not active unless the AJA Control Panel is active with a valid AJA Edit product installed on your computer.

- **Capture**—the Capture screen allows capturing video and audio to the computer from an external video/audio source, such as a VTR/DDR, using the AJA hardware.

- **Edit To Tape**—a workspace where you can perform an Insert or Assemble Edit to Tape to record your clips to a VTR/DDR.
**Application Menus**

These top-level application menus provide information and control of the workspace panes and the overall application performance.

- AJA Control Room (Mac menu only)
- File
- View
- Device
- Help

*NOTE:* Menu contents vary between the Windows and Mac menus. The following, first describes the menu items contained within the same menu across the platforms and then notes those that differ between platforms.

**File Menu**

The File menu includes these options for both Mac OS and Windows:

- **New Bin:** Opens a new blank bin panel for a new project.
- **Open Bin:** Opens a browse window to load an existing saved bin (.crbin file)
- **Import Files to Bin:** Loads EDLs for setting up batch captures adding them to the Bin.
- **Save Bin and Save Bin As:** Standard file save operations.
- **AJA Control Panel:** Opens the AJA Control Panel for setting up or changing AJA hardware.

![Figure 2. File Menu](image)

**View Menu**

The View menu offers the following view options and provides the keystroke commands for on-the-fly selection:

- **Toggle Fullscreen:** Toggles the workspace display between full screen window size and standard window size.

  The following two options are useful to hide unused setup and information space and maximize the Display Screen area while working with clip edits.

- **Show/Hide Viewer Settings:** Located below the transport bar, the Viewer Setting pane is for setting up control operations for workspaces—Capture, Playback, and Edit To Tape.
Show/Hide Bin: Located in the left column, the Bin lists and allows selection of the clips you are working with.

Viewer Mode: The last three options select one of the three workspace modes.

NOTE: For more on keystroke shortcuts, see “Keystroke Commands” on page 12.

Device Menu  If you have more than one AJA hardware device installed or connected to your computer, this menu allows you to select the one that AJA Control Room will use.

**Figure 4. Device Menu**

![Device Menu Image](image)

Help Menu Click the **AJA Software Site** link to visit the AJA website for the latest release notes, manual and AJA software downloads.

**Figure 5. AJA Control Room Help Menu**

![Help Menu Image](image)

Preferences In Windows, the Preferences screen is under the **File Menu**. For Mac OS, see the **AJA Control Room** menu for Preference settings.

This menu includes basic preferences under the following subject heads:

General Prefs: User interface and Capture option settings

**Figure 6. AJA Control Room Preferences—General**

![Preferences Image](image)
**Viewer Prefs:** Display and Timecode format option settings

*Figure 7. AJA Control Room Preferences–Viewer*

![Viewer Preferences](image)

**Serial Prefs:** Settings for serial control via selected timecode source:
- AJA Control Panel timecode settings
- Tape deck control via RS-422 port.

*Figure 8. AJA Control Room Preferences–Serial*

![Serial Preferences](image)

For information on using Capture and Output offsets to adjust Tape Deck frame accuracy, see "Tape Deck Timing Adjustment" on page 20.

**Scripting Enable and Tutorial:** For users who want to use Python Scripting to operate AJA Control Room, it is enabled here and a link to an online tutorial is available. (The tutorial is also available in Appendix A of this document.)

*Figure 9. AJA Control Room Preferences–Scripting*

![Scripting Preferences](image)
**About AJA Control Room:** In the Windows OS the **About AJA Control Room** screen is found under the Help menu. In Mac OS it is found in the AJA Control Room pulldown menu.

**Figure 10. About AJA Control Room Screen**

---

**In This Manual**

**Chapter 2** Provides detailed instructions for operating the product Clip Bin and each of the three Viewer Tabs:

- Playback
- Capture
- Edit To Tape
Chapter 2: Operation

This chapter discusses the details of using the Bin and each of the Viewer Tabs.

**Reset to Defaults:** AJA Control Room settings can be restored to factory defaults by holding down the **Control** and **Shift** keys during startup.

**Scripting AJA Control Room Operations:** AJA Control Room supports Python Scripting. A detailed reference document is available on the AJA website. See AJA Control Room Preferences>Scripting to enable this feature (refer to “Preferences” on page 7). The Preferences screen has a web-link to the documentation.

Using the Bin

The Bin is a list of links to media files in your project directory. The project directory is defined in the Preferences>General screen where you choose a Capture Path and Import Path (see “Preferences” on page 7).

You can begin a new project by selecting New Bin under the File Menu.

**Adding to the Bin:** To add a Clips and DPX folders to your project bin, you can:

- Use the **Import Files to Bin** command
- Click the plus (+) at the bottom of the Bin, then browse and select a file
- Drag media from the Finder/Explorer to the bin

To open an existing Bin that you have saved, go to the File Menu and select Open Bin, then browse and select the Bin (bin files are appended .crbin).

You may also use the Capture Tab to create a new clip and a file that is added to the Bin and your directory. This automatic bin addition feature is enabled (the default setting) or disabled via a checkbox in Preferences>General.

To remove a file from the Bin, click the trash can icon.

**NOTE:** This does NOT delete the file from your directory but removes the link from the Bin.
Moving Clips and Meta Data: The Bin panel can be expanded by dragging the right-edge to display a wide range of meta-data for each clip. Right-click on the Bin meta-data header to select the specific information columns you want to display (refer to Figure 11 on page 11).

To further organize the bin, you can drag and drop Clips in the list and do the same for the Meta-data headers.

Bin Item Right-click Menu: If you select a bin item and right-click, you will access this menu. From the menu, you can:

• Go to the project directory to access clips
• Delete the Bin Item while keeping the clip (content)
• Delete Media allows you to delete while keeping the Bin Item (no content) or delete both the item and media
• Export your project Bin as an Event to Final Cut Pro (Mac OS)
• Batch Capture clips (see “Batch Capture” on page 16)

Export to Final Cut Pro Event: Events in Final Cut Pro X (FCPX) are where you store your project footage. AJA Control Room can create an XML file that is read by FCPX which then generates an Event containing the selected files.

You can select a clip or group of clips in the bin then right-click to select Export Final Cut Pro Event.

The Final Cut Pro X application automatically launches when an Event is generated.

NOTE: In this process, files are not moved but links to them are created.
Playback Tab

The **Playback Tab** view screen is the default tab screen. When this mode is selected, AJA Control Room allows you to playback, view and trim the clips in your project.

Use playback functions for any clips that are loaded in the Bin. Double-click on a clip in the bin to open it in the Playback viewer pane.

**Figure 12. AJA Control Room Playback Tab.**

**Playback Dashboard**  
In Playback mode you can use the dashboard to jog through the clip and set IN and OUT points to trim the playback region. These edit points are also used for eventual Edit-to-Tape output.

Standard tape deck controls are available for advance, stop, and rewind.

Various methods are available to change IN/OUT and Duration values. You can enter the cursor and type values into the fields or use keystroke commands.

**Keystroke Commands:** These keystroke commands are available for manipulating the dashboard.
- Option + Play = Play reverse 1X
- Option + Frame Advance = Advance 10 frames
- Option + Frame Reverse = Reverse 10 frames
- I = set IN
- O = set OUT
- Option + I = clear set IN
Dragging Markers: You can also drag the marker elements along the timeline to set edit points. Note that active elements will display in yellow. The timeline markers (shown below) include:

- IN slider icon
- OUT slider icon
- Current Playhead Position Indicator

**Figure 13. Playback Dashboard**

Set the IN/OUT Points: Perhaps the easiest and most precise method of setting IN/OUT points, is to advance the PPI to the desired location and click the Set IN button. Then do the same for the Set OUT.

To view your clip in continuous play mode, you can click the Loop button shown below.

**Figure 14. Loop Mode, Set IN, and Set OUT Buttons and Indicators**

You can adjust the Set points by click-and-holding in the IN Position or OUT Position fields and dragging left or right.

NOTE: The IN/OUT points are displayed as either Frames or Clip Timecode values depending on your Preference settings.

Audio Meters: The Tab Settings Pane contains meters for 8 or 16 audio channels determined by the number of audio channels your AJA edit device supports. In Playback mode, you can turn audio on/off by clicking the Audio checkbox or click on any of the meter channels. Audio meter operation for Capture and Edit-To-Tape is different for each mode and is described in their respective sections in this chapter.
Capture Tab

When you have your AJA edit device (Io, or KONA) installed and running, the Capture and Edit-To-Tape tabs become active.

**Figure 15. AJA Control Room Capture Tab**

Using the Capture Tab, you can create a new clip from the input of your AJA device.

**IMPORTANT:** Remember to verify that your AJA edit device frame buffer is set (via the AJA Control Panel) for the expected video format and no unexpected conversions are taking place. In AJA Control Room you can go to File>AJA Control Panel to open the control panel (see “File Menu” on page 6).

If your input is from a Tape Deck and you have RS-422 connection, AJA Control Room provides remote control of the deck and captures according to Timecode settings for DURATION, VTR IN, and VTR OUT points (see “Playback Dashboard” on page 12).

Capture mode also supports Batch Capture which automates the process of capturing multiple clips from one or more tapes. (see “Batch Capture” on page 16).

**NOTE:** When a Capture is in-progress, the viewer is outlined in red.
**Capture Clip Settings:** The Capture Tab provides the Clip Settings pane (shown below) that allows you to enter meta-data and library information for the clip you will create. In the top row, from pulldown menus, you will select format options for the file:

- **File Type**
- **Video format (from those supported by the File Type)**
- **Audio Format (from those supported by the File Type)**

A Clip Name will be generated automatically or you can choose to enter your own designations for:

- **File Name**
- **Reel name**
- **Scene description**
- **Take designation**.

**NOTE:** If you want your information to be displayed as part of the Clip Name in AJA Control Room, you must enable the check boxes to the right of the entry field. The plus (+) buttons are used to add/increment a numeric designation.

**Figure 16. Capture Tab Settings Pane**

**Audio Channel Selection:** To select audio channels for capture:

- Single click to enable/disable channels in pairs or
- Option-click to enable/disable all available channels.
Capture Dashboard

The dashboard offers standard tape deck play controls (as described previously) and adds the jog control slider.

AJA Control Room can control a Tape Deck via RS422 or can do manually initiated captures. The Tape Deck Control icon indicates the communication status of the deck. If no active RS422 connection is present, the icon reports OFFLINE. When connected, the status will report:

- LOCAL – remote control is not enabled for the VTR
- REMOTE – the VTR is set for remote control via RS422

To activate Remote mode:

1. Verify the RS422 cable connection between your AJA device and the deck.
2. Verify the remote control mode on your recording device is enabled.

![Figure 17. Capture Buttons & Tape Deck Control Indicator](image)

NOTE: If the Tape Deck icon is lit (yellow), AJA Control Room is detecting an RS-422 connection that is active. If it is white, there is no active RS422 connection.

Two record buttons are available:

- Start tape capture—captures from the deck according to timecode VTR IN and VTR OUT settings.
- Start capture—initiates immediate manual capture of the AJA device input

Batch Capture

The batch capture procedure consists of these steps:

1. Create bin items without content by entering:
   - **File Type** and **Clip** information in the capture tab settings pane
   - **IN Point** and **OUT Point** or **Duration** information for the clip.
2. Click the Pencil icon (see Figure 17 on page 16). You will see a red line through the bin icon that indicates "Footage is offline".
   
   Repeat this process for additional bin items.

   NOTE: You can enter bin items from different tapes entering the numbers in the Tape field (Clip information). The batch capture will pause for tape change and resume to complete the batch.

3. When all the bin items are listed, select them in the bin and right-click to select Batch Capture from the resulting menu.
Next, in the options screen you can set the Capture type to:

- All Selected Items – captures content for all selected bin items, or
- Offline Items Only – captures content only for items in the bin with “footage offline”

Under Options, **Use Logged Clip Settings** is for future use. You may enable **Add Handles** to add pre- and post-footage to your captures. After setting Batch Capture Options, click Continue.

**Figure 18. Batch Capture Options Screen**

4. On the Batch Capture Screen, you may
   - Select a single item and click **Capture Clip** to capture one item
   - Click on **Capture Tape** to capture all listed items.

AJA Control Room will sequentially record multiple clips into the project directory and assign the bin item links as the capture media is run.

**Figure 19. Batch Capture Screen**

You can right-click in the bin to delete a bin item, its media content, or both, from the bin (refer to “Bin Item Right-click Menu” on page 11). If you keep the bin item and delete the media, the bin item icon’s red line returns.
Edit-To-Tape Tab

Using the Edit-To-Tape tab you can output your current clip to a tape deck or recording device using remote control. A tape deck connected via RS422 and set in remote control mode allows AJA Control Room to send an Insert Editor Assemble Edit with timecode VTR IN and VTR OUT or Duration designated.

**IMPORTANT:** Remember to verify that your AJA edit device frame buffer and output is set (via the AJA Control Panel) for the expected video format and no unexpected conversions are taking place. In AJA Control Room you can go to File>AJA Control Panel to open the control panel (see “File Menu” on page 6).

*Figure 20. Edit-To-Tape Tab*

*Edit-To-Tape Dashboard:* The dashboard for Edit-To-Tape provides the same functions as describe for Capture mode.
Edit Settings Pane

In the Edit-To-Tape settings pane, you can choose Operation Type:

- Insert – lays down selected video and audio tracks using timecode VTR IN/VTR OUT or Duration maintaining existing control tracks on the tape.
- Assemble – erases previous content and records all video, audio, timecode, and control track information onto tape according to the timecode information (VTR IN/VTR OUT/Duration) set in AJA Control Room.

Edit Track Content: The Video checkbox allows you to include/exclude Video content in an Insert Edit (not applicable to Assemble Edits). If you check the Preview box, you can use the play control to view the content in AJA Control Room without recording it to the deck.

Figure 21. Edit-To-Tape Dashboard & Tab Settings Pane

Audio Track Inclusion: In Insert mode you have complete control of the individual audio tracks you want to include in the edit. Click on each track you want to enable/disable or Option-click to enable/disable all available tracks. An Assemble edit has no control of the audio track selection.
Tape Deck Timing Adjustment

Both Capture and Edit-To-Tape operations employ Timecode for executing seamless frame-accurate operation. Latency in communication between devices can cause delays of several frames depending on the signal format and tape machine being used. To fine-tune timing between the tape deck and your computer and AJA edit device I/O, open AJA Control Room Preferences and select the Serial screen.

*Figure 22. AJA Control Room Serial Preferences Screen*

In the following procedure, you will use the **Capture Offset** for Capture timing and **Output Offset** for Edit-To-Tape. Offset values presented are in whole Frames and tenths.

**Offset Adjustment:**

The procedure is basically the same for both Capture and Edit-to-Tape adjustment. You will enter an Offset value and then capture or output-to-tape a number of clips while checking the resultant timecode accuracy. We recommend ten edits or captures (with timecode burn-in output from the VTR) be examined.

**Machine and Video Format Changes:**

If you use multiple tape deck types, you will want to perform and record these adjustments for each. Timing can vary between deck manufacturers and models. Also, changing video formats between 30 fps video (eg.1080i 29.97) and 50 to 60 fps video (720p 59.94) may require offset adjustment. Our experience indicates required offsets will be approximately:

- 2.0 frames for 30 fps formats
- 1.0 frames for 60 fps formats

**Capture Timing**

*NOTE:* For Capture testing, you can use Batch Capture to quickly generate a series of sample captures.

**Capture Adjustment Procedure:**

1. Enter your Capture Offset (1 frame for this example).
2. Set an IN Point for the Capture noting it’s timecode.
3. Set a 2 second Duration or an OUT Point.
4. Click the Tape Capture button to start the capture.
5. When Capture is complete, double-click on the clip in the bin to enter Playback mode.
6. Compare the first two frames of the burned-in timecode of the capture with the timecode values in the dashboard's Current Position Indicator (CPI).

7. If the capture resulted in a timecode beginning a frame before the CPI, adjust the offset by adding a frame. Conversely, if the clip was late, decrease the offset.

As you perform more trial captures, you may see a variance in frame accuracy. If so, you can use the tenth-of-a-frame offset (beginning with five-tenths) to make more subtle adjustment until the clip timecode and CPI consistently match.

**NOTE:** 720p 50 to 60 fps formats actually records 2 frames for each timecode frame value. For frame accuracy you must check that the timecode value does not change for the first two frames of video.

**Edit-to-Tape Timing**

For Edit-to-Tape Timing you enter frame values in the Output Offset field in Serial Preferences. AJA Control Room must begin playout so that the correct frame is on-air at the edit IN point.

**Edit Adjustment Procedure:**

1. Using a clip with timecode burn-in, select a CPI point marking the desired edit IN.
2. Set a 2 second Duration or an OUT Point.
3. Click the Tape start button to perform the edit.
4. When the edit is complete, roll the tape back to the edit IN point and verify that the first frame that was captured on tape was the frame you expected.
5. If the edit begins a frame early, adjust the offset by adding a frame. Conversely, if the clip was late, decrease the offset.

As you perform more trial edits, you may see a variance in frame accuracy. If so, you can use the tenth-of-a-frame offset (beginning with five-tenths) to make more subtle adjustment until the edit is consistently frame-accurate.

Again, for video formats of 720p 50 to 60 fps, refer to the Note above.
Appendix A: Python Scripting Tutorial

AJA has implemented a Python Scripting interface for the AJA Control Room application. Under Python script control you can:

- Name the file to be captured
- Start Capturing
- Stop Capturing

**NOTE:** Our implementation is based upon Python v2.7. Version 3.4 will not work.

This tutorial and the example files are available as a download from:

http://www.aja.com/en/software/control-room/tutorials

Python Installation

**Windows**

The Python libraries are not installed with Windows by default. You can get the Python 2.7.6 installer from:


Once this is installed, you must set an environmental variable to point to your Python installation. To add an Environmental Variable for Python:

- Right-click **My Computer**, and then click **Properties**.
- Click the **Advanced System Settings**.
- Click **Environment Variables**.
- Click one the following options, for either a user or a system variable:
  - Click **New** to add a new variable name and value.

**Figure 23. Python Environment Variable**

- Click OK

**Apple Macintosh**

Python v2.7 is installed as part of the standard Mac OSX 10.8 and 10.9 system install. No additional installation is necessary.
AJA Control Room Setup for Python Scripting

1. Copy the python folder to your desktop. It can be copied anywhere, but for this example we will expect it to be on your Desktop
2. Launch the AJA Control Room application
3. Open the AJA Control Room Preferences and
   A. Select the Scripting pane
      i. Make sure Enable Scripting Server is checked
      ii. The Scripting server port defaults to Port 8080.
   NOTE: You can change this if desired but our example code expects it to be set to Port 8080. If you modify this port number you must change the appropriate value in the code to match.
   B. Select the General pane and
      i. Make sure Hold onto device when app is in background is checked
      ii. Make sure a Capture Path is specified
   C. Dismiss Preferences window
4. Select Capture tab in Main window
   A. Specify desired File Type
   B. Specify desired Video Codec
   C. Specify desired Audio Codec
   D. Specify number of Audio Channels
   E. Confirm that the checkbox next to the File Name field is checked

Macintosh Instructions

1. Make sure the AJA Control Room app is running and is set up as described above.
   A. Open the Terminal application
   B. Type cd ~/Desktop/python/examples
   C. Type ./testcapture.py to run the testcapture Python script.

The testcapture script tells AJA Control Room to capture a 1 second clip called “testClip”. The captured clip will appear in the bin.

Figure 24. Desktop Python Examples
**Windows Instructions**

The following instructions expect the AJA Python folder to be on your Desktop. Make sure the AJA Control Room application is running.

1. Open up a **Command Prompt**

2. Type `cd %HOMEPATH%\Desktop\python\examples`

3. Type `testcapture.py` to run the testcapture Python script.

The testcapture script tells AJA Control Room to capture a 1 second clip called “testClip”. The captured clip will appear in the bin.

*Figure 25. Command Prompt Entries*

---

**Simple Modifications**

Following is the code for testcapture.py

You can change the duration of the capture by changing the number (in seconds) in the parentheses in line 15 `time.sleep(1)`

The name of the file to be captured comes from the word in quotes in line 26 (“testClip” in the example below) `captureTest(client, “testClip”)`
This script is meant to control the AJA Control Room app on the local computer, however you can control an AJA Control Room app on a different computer on the network by replacing ‘localhost’ on line 22 with the IP address (e.g. 10.192.168.40) of another computer on your network. If the Scripting server port in the Scripting Preferences has been changed you must match that port number in line 23. An instance of the AJA Control Room app must be running on the remote computer.

Figure 26. Example Python script “testcapture.py”

```python
#!/usr/bin/python
#
vim: tabstop=8 expandtab shiftwidth=4 softtabstop=4
import sys
sys.path.append("../")

from aja.controlroom_client import Client
import time

def captureTest(client, file):
    client.capture.setFileName(file)
    client.capture.startRecord()
    time.sleep(1)
    client.capture.stopRecord()

def main():
    """
    Used for testing
    """
    server = 'localhost'
    port = '8080'
    client = Client(server, port)
    captureTest(client, "testClip")

if __name__ == '__main__':
    status = main()
    sys.exit(status)
```